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Building Your First Basic Movie
This tutorial takes you through the steps of creating your first movie in Director®. If you are new to using Director, 
follow this tutorial to learn hands-on how to create a simple interactive movie with animation, sound, and video. The 
movie is designed to suggest what is possible with Director rather than simulate a fully developed Director project.

What you will learn
This tutorial introduces you to the basic skills needed to build a Director movie. These include the following:

• Setting movie properties

• Importing cast members into Director

• Placing cast members on the Stage and in the Score to create sprites, which are copies of cast members

• Animating sprites

• Creating buttons

• Scripting in Lingo to create user interactivity

• Controlling digital video and audio

• Publishing a movie on the Internet

Preparing to build the movie scenes
Before you begin to build scenes, you will get familiar with how the completed movie should look, and you will 
prepare the Stage.

View the completed movie
Start by viewing a completed version of the tutorial movie to become familiar with how your finished movie should 
look.

1 Start Director.

2 Select File > Open. 

3 Within your Director application folder, browse to Tutorials/Basics/Finished and double-click the 
Basic_finished.dir file. 

4 If windows obscure the Stage, drag them out of the way.

5 To play the movie, click the Play button at the bottom of the Stage.

6 Use the buttons in the movie to navigate from one scene to another and control the playback of the video clip. 

VolumePlay
Stop

Rewind
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The movie consists of three scenes. The first is a title scene that contains buttons for navigating to the other two 
scenes. The second scene is an animation of a tire bouncing. The third scene contains a digital video and buttons 
that control it. Each of these scenes also contain navigation buttons. 

7 When you finish viewing the movie, click the Stop button at the bottom of the Stage.

Open the movie
To begin the tutorial, open a partially completed Director file. 

1 Select File > Open.

2 Within your Director application folder, browse to Tutorials/Basics/Start and double-click the Basic_start.dir 
file. 

Note: When you open this file, Director closes the Basic_finished.dir file. If you made any changes to that file, do not 
save them.

3 Select File > Save As.

4 Name the file My_Basic_start. Save the movie in the Start folder.

By making a copy of the file, you or another user can complete this tutorial again with the Basic_start.dir file.

Set up the movie
You can now arrange your workspace and set properties for your movie, such as the Stage size and color and the 
number of channels in your Score. During the authoring process, you view Director movies on the Stage. You can 
set up the size and color of the Stage window. 

1 Select Window > Panel Sets > Default to display the default workspace.

2 If the Property inspector is not already displayed, select Window > Property Inspector.

3 In the Property inspector, click the Movie tab.

If the Property inspector is not in graphical view, as shown in the following illustration, click the List View Mode 
button to switch to the graphical view.

To see the names of buttons (like the List View Mode button), place your mouse pointer over the button. The name 
of the button appears in a floating box next to the button until you move the mouse.

4 Click the Stage Size arrow, and select 500 x 330. 

5 The size of the Stage increases.

6 If the Score is not open, select Window > Score. 

List View Mode 

Stage Size arrow
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7 In the Property inspector, type 50 in the Channels text box and press Enter (Windows) or Return (Macintosh), 
and then click OK in the dialog box that appears.

The number of channels in the Score decreases from 150 to 50, making the movie’s file size smaller.

Note: In Windows, the Enter key on the numeric keypad plays the movie. Be sure to use Enter on the alphanumeric 
section of the keyboard when entering information in Director.

8 In the Property inspector, click the Color button, and select dark gray from the color picker.

9 Select File > Save.

Note: As you complete the tutorial, remember to save your work frequently.

View your cast members
To create a Director movie, you need cast members. Cast members are the objects that appear on the Stage and in 
the Score. Some of these elements might be text, graphics, sound, video, or scripting behaviors.

The movie you create in this tutorial consists of three scenes. Some cast members appear in more than one scene, 
and some appear in one scene only. First, use the Cast window to view your current set of media. Next, you will begin 
adding new cast members. You add cast members to a Director movie by creating them in Director or by importing 
files made in other applications.

1 If the Cast window is not already open, select Window > Cast.

You can view the Cast window in two views: List and Thumbnail. In List view, you can sort cast members by 
name, number, date modified, type, and other criteria. Thumbnail view lets you see a thumbnail image of each 
cast member. In Thumbnail view, cast members are always shown in numerical order. For this tutorial, you will 
use the Thumbnail view. If your Cast window is in List view, you need to switch to Thumbnail view. 

Color button
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2 To toggle from List view to Thumbnail view, click the Cast View Style button in the upper left corner of the Cast 
window.

The Cast window contains cast members that you can use in your movie. The first is a text cast member. It contains 
the text “Trio Motor Company.” The text cast member thumbnail image that appears in the Cast window contains a 
small A icon in the lower right corner. This is the cast member type icon, and the A indicates that it is a text cast 
member.

The second cast member is a button. Button cast members have special functionality built into them, such as 
changing color when clicked, so that they behave in the way most users expect buttons to behave. This button 
contains the text “Go to Animation.” Its cast member type icon is a small square button shape.

The third cast slot is empty. You will add a cast member to that slot later. The fourth cast member is a bitmap image. 
Its cast member type icon is a paintbrush. 

The ninth, tenth, and eleventh cast slots contain bitmaps that you will use as custom buttons. Using a bitmap image 
lets you control the appearance of the button, but it does not provide the built-in functions of the Director button 
cast member type. However, you can add these functions with script, using either the Director scripting language 
called Lingo or JavaScript syntax. In this tutorial, you will use Lingo to add these functions.

Building the first scene with text and an image
Building a scene in Director requires creating or importing the cast members for the scene and placing sprites on the 
Stage. Sprites are objects that control when, where, and how cast members appear in a movie. You create sprites by 
placing cast members on the Stage or in the Score. To build the first scene of the movie, you will place sprites of the 
TitleText cast member and two buttons on the Stage. One of the buttons is already in the cast, and you will create the 
other button.

Edit a text cast member
The first cast member you will use in your movie is the text cast member containing the words “Trio Motor 
Company.” You will edit the text to give it a more appealing graphic design.

1 In the Cast window, double-click the text cast member in cast slot 1.

Cast View Style button
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The Text window opens. 

You use the Text window to edit text cast members. You will find that most Director cast member types have 
associated windows that you can use to view and edit the cast member.

Note: While completing the tutorial, you might find it useful to undo a change that you made. To undo, select 
Edit > Undo. Conversely, you can redo what you have undone by selecting Edit > Repeat.

2 Select Edit > Select All. The entire text block is selected.

3 Click the Bold button and the Italic button. The style of the selected text changes from plain to bold and italic.

4 Give the text cast member a name. Click the Cast Member Name text box at the top of the window. Then type 
TitleText, and press Enter (Windows) or Return (Macintosh).

5 Close the Text window, and save your movie.

Cast Member Name

Size

Italic
Bold
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Add sprites to the Stage
To begin building the scene, you drag the TitleText cast member, button cast member, and bitmap cast member from 
the Cast window to the Stage or Score. Because the first scene should occur at the beginning of the movie, you put the 
cast members at the beginning of the Score. The Score is discussed in detail later in this tutorial.

1 Click the Rewind button at the bottom of the Stage. This ensures that the cast members you place on the Stage 
are in the first frame of the Score, the beginning of your movie. 

2 In the Cast window, click the TitleText cast member and drag it anywhere on the Stage to create a sprite from the 
TitleText cast member.

3 The background of the new text sprite is white.

4 Click the new text sprite on the Stage to select it. 

5 On the Sprite tab in the Property inspector, do the following:

a In the Ink box, select Background Transparent.

Inks control the way a sprite color appears on the Stage. Background Transparent ink makes the white 
background of the sprite appear transparent.

b Click the Forecolor color picker, and select white.
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c In the X text box, type 15. In the Y text box, type 15, and press Enter (Windows) or Return (Macintosh). The 
text is placed at precise coordinates on the Stage.

Add sprites to the Score
When you place a cast member on the Stage, the sprite is added to both the Stage and the Score. You can also place 
cast members on the Score. When you place a cast member on the Score, the sprite is added to the Stage as well.

1 Click the Trio cast member in cast slot 6.

2 Drag the Trio cast member to the Score window so that it fills channel 2, just below the TitleText sprite. Make 
sure that the sprite begins in frame 1 of the Score.

Dragging a cast member to the Score centers the sprite on the Stage. 

Add an existing button to the Stage
In addition to the title text, the first scene of your movie will contain two buttons. You will add the first button to the 
Stage. Then you will create a new button on the Stage to complete the scene.

You begin by naming the button cast member in cast slot 2 of the Cast window. Earlier, you named the TitleText cast 
member by entering a name in the Text window. You can also give cast members names directly in the Cast window.

1 Click the button cast member in cast slot 2.

2 Click the Cast Member Name text box at the top of the Cast window, and type Animation. Press Enter 
(Windows) or Return (Macintosh).

Cast Member Name text box
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3 Drag the Animation button cast member from the Cast window to the Stage. Place it on the lower right side of 
the Stage.

4 Select the button sprite on the Stage. 

5 On the Sprite tab of the Property inspector, do the following: In the X text box, type 375. In the Y text box, type 
300, and then press Enter (Windows) or Return (Macintosh).

The button sprite is now placed at precise coordinates.

Create a new button cast member
Now you are ready to create the second button. 

Remember that button cast members contain special functionality to automatically highlight when clicked. Creating 
button cast members in Director is different from creating most other cast members. Cast members are often created 
in separate windows and then dragged from the Cast window to the Stage. You create a button cast member directly 
on the Stage, using the Tool palette. You will use the Button tool to create a new button.

1 If the Tool palette is not displayed, select Window > Tool Palette.
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2 Make sure that the Tool palette is in Classic view. At the top of the Tool palette, display the list of views and select 
Classic.

3 On the Tool palette, click the Button tool.

4 Drag a horizontal rectangle toward the right side of the Stage, as shown in the following illustration:

5 When you release the mouse button, the rectangle you created becomes an editable text box in which you enter 
the text that you want to appear on your button. Type Go to Sound and Video in the text box.

Note: If the text is too long for your button, you can enlarge the button. Click the button with the Arrow tool selected, 
and then drag the sizing handle on the right edge of the button to the right.

6 On the Sprite tab of the Property inspector, do the following: In the X text box, type 200. In the Y text box, type 
300, and press Enter (Windows) or Return (Macintosh).

7 Click the Stage outside the button. 

Button tool

Classic view
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The editable text box changes to a completed button sprite. In the Cast window, the new button cast member takes 
the next available cast slot, appearing in cast slot 3.

8 Select the new button in the Cast window.

9 In the Cast Member Name text box at the top of the Cast window, type SoundVideo and press Enter (Windows) 
or Return (Macintosh).

You have now created a new button cast member and added all of the graphic sprites for the first scene of your 
movie.

Observe the difference between sprites and cast members
As you learned earlier in this tutorial, when you drag cast members onto the Stage, you create sprites. Sprites are 
instances of cast members that appear on the Stage and in the Score window. The Score window displays all the 
frames in your movie and shows in which frames the sprites appear on the Stage. You can view information about 
sprites and edit them from both the Stage and the Score, while you view and edit cast members from the Cast 
window.

Several sprites can refer to the same cast member and can appear on the Stage simultaneously. 

1 Drag the TitleText cast member from the Cast window to the Stage a second time. 

Two TitleText sprites appear on the Stage but only one TitleText cast member appears in the Cast window. Both 
TitleText sprites are instances of the TitleText cast member.

2 In the Score, click the extra TitleText sprite on channel 4.

3 Press the Backspace key or the Delete key. 

The TitleText cast member in the Cast window remains unaffected when you delete the extra sprite.

Edit sprites in the Score window
You can shorten or lengthen sprites as needed. To make the Score information for your entire movie easier to read 
on the screen without scrolling, you will shorten the sprites for scene 1. 
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1 In the Score window, click the end of the TitleText sprite, and drag it to the left to frame 10.

Note: You can also lengthen sprites by dragging their end frames to the right to higher-numbered frames, and you 
can edit more than one sprite at the same time by selecting multiple sprite end frames. 

2 Click the Trio bitmap sprite in channel 2 of the Score.

3 Press and hold the Shift key, and click the Animation and SoundVideo sprites.

4 Click frame 10 in the frame number bar above channel 1. The playhead moves to frame 10.

5 Select Modify > Extend Sprite. 

The sprites shorten in length so they occupy only frames 1 through 10. You can use the Extend Sprite command 
to either lengthen or shorten sprites.

Change the default length of sprites
You can change the default length of sprites that you drag to the Stage and Score by editing the Sprite Preferences. 
You will now change the default sprite length to 10 frames, which makes it easier to compose a movie that consists 
only of ten-frame scenes.

1 Select Edit > Preferences > Sprite to open the Sprite Preferences dialog box.

2 In the Span Duration text box, type 10 and click OK. This new default sprite duration applies to all of your 
movies in Director, not just the movie that you are building now.

Scene 1 of your movie is almost complete. Later, you will return to this scene to add Lingo commands to the 
navigation buttons. Now you will start building scene 2.

Note: As you complete the tutorial, remember to save your work frequently.
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Building the second scene with animation
The second scene of your movie will contain a simple animation of a tire bouncing. You will import an image cast 
member for this scene and animate it to travel up and down on the screen, creating a bouncing effect. This scene will 
also include a new button that returns users to the first scene.

Place the background bitmap on the Stage
A bitmap is comprised of colored pixels arranged to form a graphic. The fourth cast member in the cast is a bitmap 
that will serve as a background for your animation. Because the animated scene will start in frame 15, you will place 
a sprite of the background on the Stage in frame 15.

• From cast slot 4, drag the black background image to channel 1, frame 15 of the Score.

When you place a sprite on the Score, Director automatically centers the sprite on the Stage.

Name a cast member
The background cast member has not yet been named. Naming cast members makes it easier to identify the sprites 
in the Score. 

1 In the Cast window, select the cast member in cast slot 4. 

2 In the Cast Member Name text box at the top of the Cast window, type Background. Press Enter (Windows) or 
Return (Macintosh). 
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Import media into Director
The tire graphic for the animation is a Fireworks® PNG file, but you can import lots of other media formats as well. 
Once a file is imported as a cast member, you can use it just as you would use any other cast member.

1 Select File > Import. 

2 In the Import Files dialog box, navigate within your Director folder to Tutorials/Basics/BasicsMedia.

3 Select the tire.png file, and click the Add button.

4 Click the Import button.

5 In the Image Options dialog box, click the OK button.

The tire has taken up the first available slot in the Cast window. The new cast member has adopted the file name 
from “tire.png” as the cast member name.

Animate the image to travel up
You are now ready to add the tire to the scene and create an animation of it bouncing. You can create the animation 
effect by placing a sprite of the tire cast member on the Stage and then moving the sprite to a new position in each 
frame. Later, you will use a technique called tweening to make the animation look more realistic.

1 From the Cast window, drag the tire cast member to channel 2, frame 15 of the Score.

2 On the Stage, move the tire sprite so that it sits just above the shadow near the bottom of the Stage.

3 With the tire sprite selected, press and hold the Shift key, click the center red dot, and drag it about one third of 
the distance toward the top of the Stage. 

By holding the Shift key, you maintain a straight vertical line in your animation.

Scrub the playhead to view your animation
You can move the playhead to preview your animation. Scrubbing the playhead is useful when you want to make 
sure that an animation or other multimedia effect works like you want it to.
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• In the Score, drag the playhead back and forth from frame 15 to frame 24. This is called “scrubbing the playhead.”

The tire moves up along the path that you just created. Now you will animate the tire returning to the ground.

Animate the image to travel down
You now have an animation of a tire rising off the ground. To animate the tire returning to its starting point, you can 
use the same method that you used when animating the tire to travel up. But you can also use a shortcut to create a 
reversed copy of the tire sprite.

1 In the Score, click channel 2 anywhere between frames 16 and 23. 

2 The tire sprite that you created previously is selected.

3 Select Edit > Copy Sprites to copy the sprite.

4 In the Score, click channel 2, frame 25.

5 Select Edit > Paste Sprites.

If you scrub the playhead at this point, you will see the tire animation repeated twice. Next, you will reverse the 
motion of the second tire animation.

6 In the Score, click channel 2 anywhere between frames 26 and 33.

The new copy of the tire sprite is selected.

7 Select Modify > Reverse Sequence.

8 Scrub the playhead from frames 15 to 34 to see the tire rise and then fall.

Extend the background across additional frames
You may have noticed as you scrubbed the playhead that the background sprite disappears as the tire falls. The 
background sprite exists only between frames 15 and 24. You can extend it to additional frames.

1 In the Score, click channel 1, frame 24 and drag it to frame 34.
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2 Scrub the playhead again. This time, the background sprite exists through the whole tire animation.

Change the tempo of an animation
For the tire animation to be more realistic, the tire should slow as it reaches the top and accelerate as it returns to the 
ground. You can achieve this effect through a technique called tweening.

1 In the Score, move the playhead to the up phase of the animation (between frames 15 and 24).

2 On the Stage, select the tire sprite.

3 Select Modify > Sprite > Tweening.

4 Move the Ease-Out slider bar to 100% and click the OK button.

The yellow dots in the animation path have become bunched close together near the top of the animation. 

5 Scrub the playhead. The tire slows as it reaches the apex.

6 In the Score, move the playhead to the down phase of the animation (between frames 25 and 34).

7 On the Stage, select the tire sprite.

8 Select Modify > Sprite > Tweening.

9 Move the Ease-In slider bar to 100% and click the OK button.
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10 Scrub the playhead. The tire accelerates as it reaches the bottom.

Change the span of an animation
It may seem that the tire is bouncing too rapidly. To make the animation run at a slower rate, you can add frames to 
the animation. You should also keep the separation between the up and down phases of the tire animation near the 
middle of the animation span. 

1 In the Score, click the end frame of the Background sprite in frame 34, and drag it to frame 50.

2 In the Score, click the end frame of the down phase tire sprite in frame 34, and drag it to frame 50.

3 In the Score, click the beginning frame of the down phase tire sprite in frame 25, and drag it to frame 33.

4 In the Score, click the end frame of the up phase tire sprite in frame 24, and drag it to frame 32.

Later in this tutorial, you will add Lingo script to make the tire animation loop.
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Add an existing navigation button to the Score
To complete the animation scene, you will add navigation buttons. First, you will use the Go to Sound and Video 
button that you created earlier for scene 1. Then you will create a new button that returns users to the first scene. 
Later, you will add Lingo to these buttons to make them function.

1 In the Score, click frame 15.

2 From the Cast window, drag the SoundVideo cast member to the lower side of the Stage. A new sprite appears 
in the Score beginning in frame 15.

3 In the Score, click and drag the end of the new SoundVideo sprite from frame 24 to frame 50.

4 On the Stage, click the SoundVideo button. 

5 In the Property inspector, display the Sprite tab.

6 On the Sprite tab of the Property inspector, do the following:

a In the X text box, type 350.

b In the Y text box, type 300, and press Enter (Windows) or Return (Macintosh).

Note: If the button is too wide to fit on the Stage, you can shrink the button. Click the button with the Arrow tool 
selected, and then drag the sizing handle on the right edge of the button to the left.

Add a new navigation button to the Score
Next, you will create a new button that returns users to the first scene.

1 In the Score, click frame 15.

2 On the Tool palette, click the Button tool.

3 On the lower left side of the Stage, drag a horizontal rectangle toward the right side of the Stage.

4 When you release the mouse button, the rectangle you created becomes an editable text box in which you enter 
the text that you want to appear on your button. Type Go to Start in the text box.

Note: If the text is too long for your button, you can enlarge the button. Click the button with the Arrow tool selected, 
and then drag the sizing handle on the right edge of the button to the right.

5 In the Cast window, select the new button cast member.

6 In the Cast Member Name text box at the top of the Cast window, type GoStart, and press Enter (Windows) or 
Return (Macintosh).

7 In the Score, drag the end of the new button sprite in channel 4 from frame 24 to frame 50.

8 On the Sprite tab of the Property inspector, do the following: In the X text box, type 15. In the Y text box, type 
300, and press Enter (Windows) or Return (Macintosh).

Arrange sprites in the Score
To make the Score easier to read, arrange the sprites of the animation scene in the Score so that there is an empty 
channel between the graphic sprites and the button sprites.

1 In the Score, select the SoundVideo sprite that begins in frame 15. 

2 Press the Shift key, and select the GoStart sprite. Both sprites should be selected.

3 Drag the two sprites down one channel so that they occupy channels 4 and 5. Be sure not to move them left or 
right. The sprites should still occupy frames 15 through 50.



ADOBE DIRECTOR 11.0
Create a basic movie

19
4 At the bottom of the Stage, click the Rewind button, and then click the Play button. 

5 The movie plays from beginning to end, flashing scene 1 briefly on the Stage and playing the tire animation once 
before returning to frame 1 and playing again. 

6 If your movie plays only once, turn on looping by selecting Control > Loop Playback.

7 When you finish viewing the movie, click the Stop button at the bottom of the Stage.

Later in this tutorial, you will add Lingo scripts to make the buttons function and prevent the playhead from moving 
from one scene to the next without navigation.

Note: As you complete the tutorial, remember to save your work frequently.

Building the third scene with sound and video
The sound and video scene will introduce you to using sound and video in your movies. You can include sound and 
video with or without Lingo, depending on the complexity of the effect you want to achieve. In this scene, you will 
add video to the Stage, add a sound effect, and add buttons that control the sound and video. 

Import a digital video cast member
When you import a file into Director, you can import the entire file into your Director movie file or leave it as a 
separate file, creating only a reference to the external file in your Director movie. If you import a file by reference, it 
is crucial not to move it from the location where it’s referenced. If you move it, Director will not be able to find it the 
next time you open your Director file, and the movie will not play as intended. Advantages of importing by reference 
include the following:

• The file size of your Director movie is smaller when you reference, rather than fully import, your media.

• Referencing media offers greater flexibility in terms of how you manage and where you locate your media assets.

When the referenced file is edited using the Launch and Edit feature of Director, there is no need to import the 
edited file again.

The first cast member in the sound and video scene will be a QuickTime® digital video file. Digital video files are 
always imported by reference, leaving the digital video file separate from the Director file.

1 Select File > Import. In the Import Files dialog box, navigate within your Director folder to 
Tutorials/Basics/BasicsMedia and select the file named walkaround.mov.

2 Click the Add button.

3 In the Media pop-up menu, select Link to External File.

By selecting the Link to External File option, you specify importing by reference.

4 Click the Import button.
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The new digital video cast member appears in the Cast window in the first available cast slot. It is named after 
the imported file.

Play the digital video
You can view the QuickTime cast member by opening the QuickTime window. This window contains controls for 
playing the video file but not for editing the video; you cannot edit digital video files in Director.

1 In the Cast window, double-click the walkaround cast member. 

2 The QuickTime window opens.

3 Play the video by using the controls at the bottom of the QuickTime window:

a Click the Play button in the lower left corner of the window. The video begins playing, and the Play button 
changes to a Pause button.

b To pause the video, click the Pause button in the lower left corner of the window. The video pauses, and the 
Pause button reverts to a Play button. 

The QuickTime window has its own playhead that moves to the right as the video plays. You can use the 
playhead to jump to a specific point in the video or to scrub through the video. 

c To jump to a specific point in the video, click in the bar to the right or left of the playhead. The playhead 
moves to the point that you clicked in the bar, and the window displays the corresponding frame of video.

d To scrub through the video, drag the playhead to the right to scrub forward and to the left to scrub in reverse.

4 When you finish playing the video, close the QuickTime window.
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Create a QuickTime sprite
You are now ready to place the QuickTime sprite on the Stage. The sound and video scene should start in frame 55.

1 In the Score, in channel 1, click frame 55. The playhead moves to frame 55.

2 From the Cast window, drag the walkaround QuickTime cast member to near the top-center of the Stage. 

The new sprite appears on the Stage and in the Score in channel 1, frames 55 through 64.

Specify direct-to-Stage playback for a QuickTime cast member
Director can play QuickTime video using direct-to-Stage playback, which lets the video play at the fastest possible 
speed. When direct-to-Stage playback is selected for digital video, the video appears in front of all other sprites, 
regardless of the channel that contains the sprite. To verify that direct-to-Stage playback is selected for the new 
QuickTime sprite, complete the following steps.

1 In the Cast window, select the walkaround cast member. (Make sure that you do not select the sprite on the 
Stage.)

2 In the Property inspector, select the QuickTime tab.

3 On the QuickTime tab, verify that the DTS checkbox is selected. DTS stands for direct-to-Stage.

The Video, Audio, and Streaming check boxes should also be selected, by default. 

Add custom buttons
Next, you will add buttons that control playback of the QuickTime sprite. These buttons are already included in the 
Cast window in cast slots 9, 10, and 11. Unlike the standard Director button cast members, these cast members are 
bitmap graphics that do not include automatic button functionality. Later, you will add Lingo to the buttons to make 
them control the QuickTime sprite. 

1 In the Score, in channel 2, click frame 55 if the frame is not already selected.

2 In the Cast window, find the Play cast member and drag it to the Stage. Place the Play button on the Stage under-
neath the QuickTime sprite. Because you will align all three buttons soon, do not worry about precise placement yet.
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The Play button’s sprite appears on the Stage and in channel 2, frames 55 through 64, of the Score.

3 In the Cast window, find the Pause cast member and drag it to the Stage. Place the Pause button on the Stage 
underneath the QuickTime sprite, just to the right of the Play button. Again, precise placement is not necessary yet.

The Pause button’s sprite appears on the Stage and in channel 3, frames 55 through 64, of the Score.

4 In the Cast window, find the Rewind cast member and drag it to the Stage. Place the Rewind button on the Stage 
underneath the QuickTime sprite, just to the right of the Pause button.

The Rewind button’s sprite appears on the Stage and in channel 4, frames 55 through 64 of the Score.

5 In the Score or on the Stage, press the Shift key and click the three buttons. 

All three buttons are selected, so you can now place all three of them precisely on the Stage.

6 Select Window > Align.

The Align tab on the Design panel is displayed on the lower right side of the screen.
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7 On the Align tab, click the Align Vertical Center button. This option aligns the buttons along the X axis.

8 On the Align tab, click the Distribute Horizontal Center button. This option unifies the distances between the 
three buttons.

Later in this tutorial, you will add Lingo to these custom buttons to make them functional.

Import a sound
The QuickTime movie has no sound track. You can make the scene more interesting by adding sound to accompany 
the video. The easiest way to add sound to a Director movie is to import a sound cast member and place it in one of 
the sound channels in the Score. Whenever the playhead plays frames that include sound sprites, the sound plays. 
You can also play sounds by using Lingo instead of the sound channels, which you will learn later in this tutorial.

1 Select File > Import. 

2 In the Import Files dialog box, navigate within your Director application folder to Tutorials/Basics/BasicsMedia 
folder, and open the Sounds folder.

3 Select the sound file named track1.mp3, and click the Add button.

4 In the Media box at the bottom of the dialog box, select the Link to External File option. 

This option tells Director to import only a reference to the file, leaving the sound file separate from the Director 
movie file. 

5 Click the Import button. The track1 sound file is imported into the Cast window.

Add a sound to the Score
Now you can add the sound to the Score. Because sounds are heard and not seen, they do not appear on the Stage. 
You place sound sprites directly in the Score. 

Align vertical center

Distribute horizontal center
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1 In the Score, click the Hide/Show Effects Channels button if the effects channels are not visible. The effects 
channels should appear above the frame number bar in the Score. 

The Hide/Show Effects Channels button

How the effects channels should look when they are visible

2 In the Score, click frame 55. 

3 From the Cast window, drag the track1 cast member to frame 55 in sound channel 1 of the Score.

The sound is now ready to play when frames 55 to 64 of your movie play. 

4 Rewind and play your movie. 

The playhead moves through the frames of your movie quickly. There is not enough time for the QuickTime 
sprite or the track1 sound to play through before the playhead reaches frame 64. Later, you will add Lingo to solve 
this problem.

5 When you finish viewing the movie, click the Stop button at the bottom of the Stage.

Add navigation buttons
The last sprites that you will add to the sound and video scene are the navigation buttons. You will then be ready to 
add some simple Lingo script, the Director scripting language, to the buttons.

The sound and video scene needs a button that returns users to the start scene and a button that is linked to the 
animation scene. You already have each of these buttons in the Cast window and in the Score. You will use two 
slightly different techniques to place these buttons in the sound and video scene.

Sound channels
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You used the GoStart button in the animation scene and placed it at the very bottom left corner of the Stage. Since it 
is appropriate for that button to be in the same location on the Stage in the sound and video scene, you can use the 
same sprite for both scenes. By simply lengthening the GoStart button sprite from the animation scene, you can 
extend it in the Score to the sound and video scene. When you do this, the button occupies the same space on the 
Stage in both scenes.

After lengthening the GoStart sprite, you will need to add the button that navigates to the animation scene. Because 
the button will occupy a different location on the Stage than it did in the start scene, you will make a new sprite for 
it in the sound and video scene. 

1 On the Score, find the GoStart sprite in channel 5 and drag its end frame to frame 64. 

The sprite lengthens in the Score and appears in the lower left corner of the Stage in the sound and video scene.

2 On the Score, select frame 55 in channel 6.

3 From the Cast window, drag the Animation cast member to the Stage, placing it in the lower right corner of the 
Stage.

The new Animation button sprite appears on the Stage and in frames 55 through 64 in channel 6 of the Score. 
Because you already selected frame 55 in channel 6, the sprite appears in that location when you drag it to the 
Stage. If you do not preselect a channel in the Score, the sprite appears in the first available channel in the frame 
where the playhead is located. 

4 On the Stage, click the Go to Animation button. 

5 Use the Sprite tab in the Property inspector, as you did earlier, to give the button an x coordinate of 350 and a y 
coordinate of 300.

Each scene of your movie is graphically complete. You are now ready to add Lingo to the buttons, to let users 
navigate through the movie.

Note: As you complete the tutorial, remember to save your work frequently.

Writing scripts to control the movie
By scripting, you can implement almost any kind of user interaction and multimedia effect that you can imagine. 
You can make simple buttons function, as you will soon do in this tutorial. You can also script more complex tasks, 
including controlling every aspect of a movie’s content without using the Score.
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Director supports scripting in two languages: Lingo and JavaScript syntax. In this tutorial, you will script in Lingo 
only, but if you are already familiar with JavaScript, you may want to try JavaScript syntax instead. Lingo is designed 
to be easy to learn, so don’t be intimidated. After you know the basic concepts, you can use the extensive scripting 
vocabulary to control anything in your movie.

Looping the playhead with Lingo
The scenes of your movie are not much good as scenes if the playhead simply races through them without stopping 
to let the user absorb their content. In this movie, the playhead must stay in one scene until the user makes a decision 
to go to a different scene. In this tutorial, you will add Lingo to a special Script channel in the Score and to your 
button sprites.

To make the playhead stay in one scene, you loop it in a single frame or a series of frames. For the start scene and the 
sound and video scene, the playhead can loop in one frame. For the animation scene, where the animation occurs 
over a series of frames, the playhead should loop over the same series of frames.

To control the movement of the playhead without using buttons, you use the Script channel in the Score. As with the 
sound channels, the Script channel is one of the effects channels that appear above the frame number bar in the 
Score. 

Write a handler
The start scene is the first one that needs a script to loop the playhead. Each time the playhead leaves one frame to 
go to the next, an event, called an exitFrame event, occurs. In this case, the word event refers to an action executed 
in Director. Your first script will use the exitFrame event as its trigger. 

Each script you write is composed of handlers. A handler is a set of Lingo commands that handle a specific event, 
such as the exitFrame event. Some scripts have only one handler and some have multiple handlers. Each handler 
begins with the name of the triggering event, such as exitFrame, and ends with the word end.

When you need to enter or edit scripts in Director, you use the Script window. Each script becomes a cast member. 
The Script window contains tools for editing scripts easily. 

1 In the Script channel of the Score, double-click frame 10, the last frame of the start scene. The Script window 
opens, and it already includes a default handler:

on exitFrame me

end

2 In between these two lines of script, enter the following additional script:

_movie.go(_movie.frame)

The result is a handler that should look like this:

on exitFrame me
_movie.go(_movie.frame)

end
3 Close the Script window. The new script cast member appears in the Cast window in the first available cast slot. 
A sprite for the script also appears in the Script channel in frame 10. 

Script channel
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4 In the Cast window, select the new script. 

5 In the Cast Member Name text box at the top of the Cast window, type Loop. Press Enter (Windows) or Return 
(Macintosh).

6 At the bottom of the Stage, below the movie, click the Rewind button. Then also at the bottom of the Stage, click 
the Play button to play your movie. 

7 The movie plays to frame 10 and stops. The movie continues to play, even though it loops at frame 10. 

8 At the bottom of the Stage, click the Stop button to stop the movie.

• The handler that you wrote has three parts: 

• The first line, on exitFrame me, tells Director to run this script when the playhead leaves the frame where the 
script is located. This is frame 10. 

• The second line, beginning with _movie.go, tells Director to send the playhead back to the current frame. The 
.frame in (_movie.frame) always refers to the frame number where the playhead is currently located. Again, this 
is frame 10. 

• The last line of any handler contains the word end. It signals the end of the script. 

The result of the new handler is that the playhead continually loops in frame 10 as it is sent back to frame 10 each 
time it tries to go to frame 11. Your Director movie plays to frame 10 and loops there until the user clicks a button 
to go to a different scene.

Reuse the handler
You can use the same script cast member in the last frame of your movie, frame 64. The script creates the same 
looping effect in frame 64 for the sound and video scene as you achieved in frame 10 for the start scene.

1 Make sure that the Cast window and Score are open.

2 In the Score, display frame 64.

3 From the Cast window, drag the Loop script cast member to frame 64 in the Script channel of the Score. 

A new sprite for the script appears in frame 64. The default length of script sprites is one frame. Now the same 
looping effect from frame 10 also occurs in frame 64. So the movie keeps playing the sound and video scene until 
the user clicks a button. 

Add a marker to the Score
In the animation scene, you constructed an animation that takes place from frame 15 to frame 50. If you loop the 
playhead only in frame 50, the animation does not play while the movie is waiting for the user to click a button. In 
this case, you should loop the playhead over the entire range of frames that contain the animation.

To do this, you can use a script that is similar to the one you just wrote and place it in the last frame of the animation 
scene. However, this new script will send the playhead to the first frame of the animation rather than to the frame 
where the script is located. 

Because the first frame of the animation scene is frame 15, you could simply write a script that says:

_movie.go(15)
The problem with this script is that it is not flexible. If you decide to move the animation scene to a different range 
of frames in the Score, the script would be incorrect. To make the script more flexible, you can place markers in the 
Score and send the playhead to a marker rather than a specific frame number. 
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Markers are a way of giving a name to a specific frame in the Score. If you name the first frame of the animation scene 
and then decide to move the scene, you can simply move the marker in the Score along with the rest of the scene.

1 In the Score, display frame 15.

2 Click the Marker bar above frame 15. 

A new marker appears in the Marker bar in frame 15. The text box next to the new marker contains “New 
Marker” as placeholder text.

3 In the text box next to the new marker, type Animation, and press Enter (Windows) or Return (Macintosh) to 
name the marker.

Create navigation in Lingo using marker names
1 You can write a script that loops the playhead in frames 15 through 50 using the name of the marker.

2 Double-click the Script channel in frame 50, the last frame of the animation scene. The script window opens with 
the default on exitFrame script already entered.

3 Inside the default script, on line 2, type the following:

_movie.go("Animation")
4 In the Name text box at the top of the window, type AnimLoop, and close the Script window. 

The new script cast member appears in the first available cast slot of the Cast window, and the new sprite appears 
in frame 50 of the Script channel in the Score. 

5 Click frame 15 in the frame number bar in the Score, and click the Play button at the bottom of the Stage. 

The animation scene plays, and the playhead loops back to frame 15 when it reaches frame 50. The animation of 
the tire bouncing repeats continuously.

6 Click the Stop button at the bottom of the Stage.

Each of the scenes in your movie has a script that prevents the playhead from moving to a different scene. Now you’ll 
add scripts to the navigation buttons so the user can move from scene to scene.

Add Lingo to navigation buttons
To make the navigation buttons function, you need to add scripts to the buttons. These scripts should be attached to 
the button sprites, rather than to frames in the script channel. Your frame scripts respond to exitFrame events. After 
you write the button scripts, they will respond to mouse clicks.

Marker menu
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You start by adding scripts to the button sprites in the start scene. 

1 In the Score, display frames 1 through 10.

2 Right-click (Windows) or Control-click (Macintosh) the Animation button sprite in channel 3, frames 1 through 
10.

3 In the context menu, select Script. 

The Script window opens with a default handler entered:

on mouseUp me

end
4 On the second line, type the following script:

_movie.go("Animation")

You see the following result:

on mouseUp me
_movie.go("Animation")

end

5 In the Name text box at the top of the Script window, type GoAnim.

6 Close the Script window, and save your movie.

This handler has three parts. The first line tells Director to trigger this handler when the user clicks on the button 
sprite to which the script is attached. Specifically, the mouseUp event refers to the action of releasing the mouse 
button after it has been pressed. This way the script does not run until the user releases the mouse button when 
clicking.

The second line of the handler contains the same code as the previous script that you wrote. It sends the playhead 
to the frame that contains the marker named Animation. The difference between these two scripts is that this 
one performs its action based on a mouse click, not on an exitFrame event.

Again, the word end on the last line tells Director that the script is finished.

Test your script
You are now ready to try out your new button script.

1 If necessary, bring the Stage window to the foreground by clicking its title bar.

2 Rewind and play your movie. 

The movie plays, and the start scene remains on the screen. The playhead does not move to another scene until 
you click your newly scripted button.

3 Click the Go to Animation button on the Stage. 

The button provides feedback by changing color when it is clicked. The playhead moves to the first frame of the 
animation scene, and the tire bounces. 

4 Stop your movie.

Add markers to two additional scenes
Your first button is complete. To use similar scripts on the remaining navigation buttons, you can add markers to the 
start scene as well as the sound and video scene.
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1 Display frame 1 of the Score.

2 In the Score, click the marker bar in frame 1, the first frame of the start scene.

A new marker appears. 

3 In the text box next to the new marker, type Start, and press Enter (Windows) or Return (Macintosh).

4 Display frame 55 of the Score.

5 Click the marker bar in frame 55, the first frame of the sound and video scene. 

6 In the text box next to the new marker, type SoundVideo, and press Enter (Windows) or Return (Macintosh).

Write script that refers to scenes
You can write scripts that refer to any of the three scenes by name. You can now add a script to the Go to Sound and 
Video button in the start scene.

1 In the Score, display frames 1 through 10.

2 In frames 1 through 10, right-click (Windows) or Control-click (Macintosh) the SoundVideo sprite. 

3 In the context menu, select Script. 

The Script window opens with the default on mouseUp handler.

4 On the second line of the handler, type: 
_movie.go("SoundVideo")

5 In the Name text box at the top of the Script window, type GoSndVid.

6 Close the Script window, and save your movie.

7 To test the script, rewind and play your movie, and then click the Go to Sound and Video button in the start 
scene.

The movie jumps to the sound and video scene, and the QuickTime sprite plays.

Add scripts to the animation scene
The animation scene contains two buttons: the Go to Start button and the Go to Sound and Video button. Because 
you already have a script for the Go to Sound and Video button, you can reuse it. For the Go to Start button, you 
need to write another new script.

1 Make sure that the Cast window and the Score are both open.

2 Display frame 15 of the Score.

3 From the Cast window, drag the GoSndVid script cast member onto the SoundVideo button sprite that appears 
in frames 15 through 50 of the Score. 

The script is now attached to this sprite in the same way it is attached to the SoundVideo button sprite in scene 1.



ADOBE DIRECTOR 11.0
Create a basic movie

31
4 To write a new script for the Go to Start button, right-click (Windows) or Control-click (Macintosh) the GoStart 
button sprite that starts on frame 15 of the Score. 

5 Select Script from the context menu. 

6 The Script window opens with the default on mouseUp handler. 

7 On the second line of the handler, type the following:

_movie.go("Start")
8 In the Name text box at the top of the Script window, type GoToStart, and then press Enter (Windows) or Return 
(Macintosh). 

9 Close the Script window and save your movie.

Because this Go to Start button sprite extends all the way into the sound and video scene, you do not need to do 
anything else to enable the button in that scene. The last step to enable all the of navigation buttons is to add the 
GoAnim script to the Go to Animation button in the sound and video scene.

Add one more script to the sound and video scene
You already added the navigation script to the Go to Start button in the sound and video scene. To complete the 
navigation buttons, you only need to add a script to the Go to Animation button. 

1 Make sure that the Cast window and the Score are both open.

2 Display frames 55 through 64 of the Score.

3 From the Cast window, drag the GoAnim script onto the Animation button sprite in frames 55 through 64 of the 
Score.

Your movie’s navigation functionality is now complete. You can now move among all three scenes of your movie. 

4 Rewind and play your movie.

5 Use each of the navigation buttons in all three scenes. Verify that each button sends the playhead to the correct 
scene.

Controlling digital video with script
Although Director movies and digital video movies share some similarities, differences also exist between the two 
types of movies. Both Director movies and digital videos comprise a sequence of frames that display on the screen. 
Director plays its movies by moving the playhead through the Score and displaying each frame the playhead comes 
to. If the computer on which the movie plays is slow and takes a long time to display each frame, then the Director 
movie plays slowly. The way that Director plays movies is called frame-based animation. 

Digital video movies use a timeline instead of a Score. The timing of the video playback is tied closely to the sound 
track of the video. For example, if the video has a sound track, the timing of the video and sound must remain 
synchronized during the entire playback of the video. For this reason, digital videos will skip frames if necessary to 
keep up with the sound track. On slower computers, several frames might be skipped during video playback. This 
kind of animation is called time-based. These differences are the reason you navigate a Director movie by jumping 
to different frames in the movie, and you navigate a digital video by jumping to different times within the video. 

Now you are ready to add scripts to the bitmap graphic buttons for controlling the digital video playback. The bitmap 
graphic buttons are a Play button, a Pause button, and a Rewind button. For these buttons, you use some new 
scripting terms, including the movieRate and movieTime properties of the QuickTime sprite. By changing the 
values of these properties with Lingo, you change the way the video plays on the Stage.
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When the user navigates to the sound and video scene from a different scene, the digital video plays from start to 
finish once. To play the video again without first leaving the scene, you need to rewind it. You rewind the video by 
setting its movieTime property. 

The movieTime property indicates the time, within the digital video, that currently appears on the screen. The 
movieTime is measured in ticks, or 60ths of a second. For example, when the movie displays the very first frame of 
video, the movieTime is 0. When 1 second of the video has played, the movieTime equals 60. When 3 seconds of the 
video have played, the movieTime equals 180. By setting the movieTime to a number that you select, you can make 
the video jump to a different frame.

Rewind the QuickTime sprite
You can rewind the QuickTime sprite by setting its movieTime to 0.

1 In the Score, display frames 55 through 64.

2 In frames 55 through 64, right-click (Windows) or Control-click (Macintosh) the Rewind button sprite.

3 Select Script from the context menu. 

The Script window opens with a default on mouseUp handler already entered.

4 On the second line of the handler, type the following Lingo to rewind the QuickTime sprite:

sprite(1).movieTime = 0

5 Press Enter (Windows) or Return (Macintosh). 

6 On the third line of the handler, type the following Lingo:

sprite(1).movieRate = 0

The movieRate property indicates the speed at which the QuickTime sprite is playing. When the video is 
stopped, the movieRate is 0. 

The result looks like this:

On mouseUp me
sprite(1).movieTime = 0
sprite(1).movieRate = 0

end

7 In the Name text box at the top of the Script window, type RewindScript. 

8 Close the Script window, and save your movie.

9 Rewind and play your movie. 

10 In the start scene, click the Go to Sound and Video button.

The movie jumps to the sound and video scene, and the QuickTime sprite begins to play.

11 When the QuickTime sprite finishes playing, click the Rewind button on the Stage. The QuickTime sprite 
rewinds to the beginning of the video.

Add a script that plays the QuickTime sprite
When the video is playing normally, the movieRate is 1. You can now add the movieRate property to the Play 
button. This time, scripting makes the QuickTime sprite play when the user clicks the Play button in the movie on 
the Stage.

1 In the Score, right-click (Windows) or Control-click (Macintosh) the Play button sprite in frames 55 through 64. 
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2 Select Script from the context menu. 

3 In the Script window, on the second line of the handler, type the following Lingo:

sprite(1).movieRate = 1

This script starts the QuickTime sprite playing at normal speed.

4 In the Name text box at the top of the Script window, type PlayScript. 

5 Close the Script window, and save your movie.

Add a script that pauses the QuickTime sprite
When the video is paused, the movieRate is 0. You can play a video at faster than normal speed by using numbers 
greater than 1 and at slow speed by using numbers less than 1. 

1 In the Score, right-click (Windows) or Control-click (Macintosh) the Pause button sprite in frames 55 through 
64.

2 Select Script from the context menu. 

3 On the second line of the handler in the Script window, type the following Lingo:

sprite(1).movieRate = 0

This Lingo pauses the QuickTime sprite.

4 In the Name text box at the top of the Script window, type PauseScript. 

5 Close the Script window, and save your movie.

6 Now all your video control buttons work. Rewind and play your movie to test the buttons.

Control sound with script
The sound and video scene plays the sound file that you placed in the Score, but only the first time you go to the 
scene. You can add script to make the music play each time you play the video. You can also add script to make a 
short sound effect play when the video control buttons are clicked. 

To control sound with script, you use commands that are specifically intended for use with sounds. In this tutorial, 
the first step is to add Lingo to play the track1 sound when the video plays a second time. For this task, add a play 
function to the PlayScript cast member that you have already written in Lingo.

1 In the Cast window, select the PlayScript cast member. 

2 Click the Cast Member Script button near the upper right corner of the window. 

The Script window opens with the Lingo from the PlayScript cast member visible.

Cast Member Script button
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3 Place the insertion point at the end of the second line of the handler that reads as follows:

sprite(1).movieRate = 1 

4 Press Enter (Windows) or Return (Macintosh), and type the following on the new line: 

sound(1).play(member("track1"))

This Lingo tells Director to play the sound cast member named track1 in sound channel 1. In the Score, there 
are two sound channels. When you use Lingo, you can use as many as eight sound channels. 

5 Close the Script window, and save your movie.

6 Rewind and play your movie. The track1 sound now plays each time you press the Play button in the sound and 
video scene of the movie.

Modify the script for the Pause button
Now you need to modify the PauseScript cast member so that the sound pauses when the user clicks the Pause button 
on the Stage to pause the video.

1 In the Cast window, select the PauseScript cast member.

2 Click the Cast Member Script button in the upper right corner of the Cast window. The Script window opens 
with the PauseScript Lingo displayed.

3 Place the insertion point at the end of the second line of the handler that reads as follows:

sprite(1).movieRate = 0

4 Press Enter (Windows) or Return (Macintosh). On the new line, type the following:

sound(1).pause()

This Lingo tells Director to pause the sound in sound channel 1.

5 Close the Script window and save your movie.

Now when you click the Pause button in the sound and video scene of the movie, the sound and video pause at the 
same time. When you click the Play button in the movie again, the video resumes and the sound plays again.

Modify the script for the Rewind button
You can modify the RewindScript cast member so that the sound stops when the user clicks the Rewind button.

1 In the Cast window, select the RewindScript cast member.

2 Click the Cast Member Script button in the upper right corner of the Cast window. 

3 In the Script window, place the insertion point at the end of the third line of the handler that reads as follows:
sprite(1).movieRate = 0

4 Press Enter (Windows) or Return (Macintosh). On the new line, type the following:
sound(1).stop()

This Lingo tells Director to stop the sound in sound channel 1.

5 Close the Script window, and save your movie.

Now when you click the Rewind button in the sound and video scene of the movie, the video rewinds and 
the sound stops playing. When you click the Play button in the movie, the video restarts and the sound plays 
again.
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Add sounds to buttons
The final effect to add is to make a short sound play when users click any of the video control buttons in the sound 
and video scene. This sound file is small; there is no compelling reason not to import the file directly into your 
Director file. Then you will add a play function to each of the scripts that are attached to the video control buttons. 
This command plays the new sound cast member in the second sound channel.

1 Select File > Import. 

2 In the Import Files dialog box, navigate within your Director folder to Tutorials/Basics/BasicsMedia/Sounds.

3 Select the file named button.wav, and click the Add button.

4 In the Media pop-up menu, select Standard Import.

5 Click the Import button. 

6 The new sound cast member appears in the Cast window in the next available cast slot.

7 In the Cast window, select the RewindScript cast member.

8 Click the Cast Member Script button in the upper right corner of the Script window. 

9 In the Script window, create a new line after the first line of the handler.

10 On the new line, type the following Lingo:

sound(2).play(member("button"))

The (2) specifies the second sound channel.

11 Close the Script window, and save your movie.

12 Repeat steps 6 through 10 for the PlayScript and PauseScript cast members.

You have now completed authoring your Director movie. You can play the movie and move from scene to scene with 
the navigation buttons that you created. You can control the playback of the digital video with the bitmap graphic 
buttons that you added. Next, you will publish the movie to play on the web.

Publishing your movie
In general, you can publish your movie for the web by simply selecting File > Publish. Using default Publish settings, 
Director creates a Shockwave version of your movie, with the Director movie (DCR) extension, in the same directory 
as your original movie. An HTML page includes the necessary tags to embed the movie. Your browser window 
opens, and your Shockwave content plays within the browser.

When you use QuickTime video, you must complete a few additional steps to ensure that your movie plays correctly. 
These steps involve specifying that a QuickTime Xtra extension downloads to your user’s system, if necessary, and 
placing your files in a specific folder if you are publishing your movie on a local computer.

If you publish a movie without saving it, Director displays a message requiring confirmation to save the movie. If you 
do not save the movie, the movie is not published. External casts (.cst) used in a movie you are publishing are copied 
to the publishing folder automatically.
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Use a QuickTime Xtra extension
Xtra extensions are software components that extend the functionality of Shockwave content and projectors. A 
QuickTime Xtra extension is necessary to ensure your QuickTime movie plays correctly when published. When you 
imported the QuickTime movie, Director automatically added the QT3 Asset Xtra to the Xtra extensions list for your 
movie. You now need to select the Xtra extension from the list to make it available to your users.

1 Select Modify > Movie > Xtras.

2 In the Movie Xtras dialog box, select the following Xtra extension, according to your operating system:

• Windows users should select QT6Asset.x32.

• Macintosh users should select QuickTime Asset.

Note: Both versions of the QuickTime Xtra extension are cross-platform.

3 Select the Download if Needed check box.

4 Click the OK button.

5 Save your movie.

The Xtra extension will now download transparently to the user’s computer, from a secure server, if the user does 
not have the Xtra extension.

Change Publish settings and publish your movie
When you use the Publish command, you can take advantage of the default Publish settings of Director, or you can 
modify them with the Publish Settings dialog box.

For the tutorial movie, you will publish the movie using the Detect Shockwave HTML page which, in addition to 
including OBJECT and EMBED tags that are necessary to display your movie correctly in a browser, includes JavaScript 
that detects if your user has the correct version of Shockwave Player. If necessary, a message appears that advises your 
user to update the Shockwave Player installation.

1 Select File > Publish Settings.

2 On the Formats tab of the Publish Settings dialog box, select both Shockwave File (DCR) and HTML. None of 
the other Publish options should be selected.

3 Verify that Preview after publishing is selected.

4 In the Files tab, verify whether the Copy linked and dependent files option is selected.

5 Click OK

6 Save your movie.

7 Select File > Publish. 

Your browser opens and plays your tutorial movie.

When you save your movie, Director also saves any changes you made in the Publish Settings dialog box. The next 
time that you want to publish your movie in the same way, you can simply select File > Publish without having to 
modify the Publish Settings dialog box again.
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Summarizing what you learned
By completing this tutorial, you have become familiar with the basic tasks and procedures used to create Director 
movies. You now know how to do the following:

• Import cast members

• Edit movie properties

• Create sprites

• Use inks

• Animate sprites

• Create bitmap graphics

• Create vector shapes

• Create button cast members

• Edit the Score

• Use sounds

• Write simple Lingo scripts

• Publish your movie for web playback
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